Introduction to pangeo

Hi everyone.
I’m new to Pangeo.
I tried to run this example, but, when I tried to load data from Pangeo data, I got a value error (ValueError: group not found in the path).
I got this error without making changes to the code.
I tried to change the data source using data source from another examples or change my code using a solution to this problem with GitHub:
but this didn’t solve my problem.

I use python 3.8 on win10

How i can solve this problem?

1 Like

Hi @frolui and welcome to Pangeo.

That example is a bit out of date. A more recent one lives here:

Our website is in need of an update!

1 Like

Hi @rabernat!
Thank you for solution of my problem.
I tried to run examples from your link, but got this error:
ValueError: Bad Request:
b’User project specified in the request is invalid.’

I think I need to look for some kind of working data source.

This dataset has been moved to “requester pays” mode:

You can access it from or Pangeo binder. If you want to access it from your own environment, you will need to connect it to a Google Cloud project in order to pay the egress fees.

Hi @rabernat!
Thank you for your answer.

Hi @rabernat - I hit the same problem, but might have time to do a PR for the website. Wondering if there is an alternative small free dataset that could be proposed instead?


1 Like

Thanks for your suggestion Liam! The catch is, for small data you don’t need the things that this example shows off (zarr, lazy loading, distributed dask cluster etc.)

For reference, all our examples have now moved to