Problems running opencv

When running “import cv2” the following message appears:
ImportError: cannot open shared object file: No such file or directory

When I run in desktop environment on jupyter notebook, it runs normally.

Thanks if you can suggest a solution.

OpenCV is not currently part of the Pangeo notebook environment, which means you must be installing it yourself. How are you installing it?

Because of the many dependencies of opencv, it would probably be best to add it directly to the Pangeo docker image.

I used the command: “pip install opencv-python” and the return was: “Successfully installed opencv-python-”.

How do I install using the Pangeo docker image?

I see that opencv is on conda-forge.

Yes, i tried with “conda install -c conda-forge opencv”, but without sucess.

@mmaranhao , you would need to submit a PR like this to get opencv added.

How and to whom do I make this request to include the opencv?

@mmaranhao if you are unfamiliar with pull requests, check this out: Creating a pull request - GitHub Docs