Pangeo binder getitems() error accessing MUR data

hello! i’m trying to run a script that access AWS MUR SST data from a pangeo binder and i get this error message:
TypeError: getitems() got an unexpected keyword argument 'on_error’

it worked before, and i can run it from a cloud server from work (in which i sign in with a personal account).
i appreciate your help, since i’m at a lost on how to fix this.

1 Like

Thanks for the question! I think we can help you solve this.

Could you please post a link to the binder repo in question? It would be very helpful for us to see the full code and environment. Without these, it’s hard to debug.

My hunch is that this is an intake and / or fsspec version incompatibility.

this is the repo, the main branch

and i have a sense you’re right ryan, about the version incompatibility. just don’t know how to go about it.

I ran your notebook (Ch6_Ocean_Example.ipynb) and reproduced your problem. Then I ran

pip install --upgrade zarr fsspec s3fs

and it went away.

I see you are using an environment which pins very old versions of all your packages:

Definitely don’t do that! If you’re looking for an up-to-date image, I recommend pangeo-docker-images.

thanks ryan!
updating the libraries needed few passes to make sure all of them are up to date. now things are running smoothly.
i’ll check the docker images.