Issues getting started with dask-labextension


I’m trying to set up the dask-labextension on my Azure VM. I installed it via conda using a custom environment “pangeo”. However, it seems I haven’t managed to build it correctly as the extension doesn’t show up in the Jupyter lab panel. I attach a screenshot showing a list of the extensions installed in my conda environment.

I would appreciate any guidance, particularly if you have a workaround in Azure VMs.



1 Like

Looks like you got version 4.0.1. There’s a 5.x version available, at least through pip and conda-forge. Can you try that? 5.x includes some changes to the labextension to not require a jupyterlab rebuild step.

1 Like

@TomAugspurger thanks for the reply. I used the default environment to set up the latest version of dask-labextension, which seems only to work only with Jupyter 3.x version. However, the issue remains as I don’t see the extension symbol at the panel.

When I inspect the Jupyter Lab version through the menu (Help > version), it says 2.1.4 (see the image below). I was wondering if there is a way to choose the specific Jupyter Lab version when before launching the Azure VM. This could be the underlying reason of the conflicts to installing the dask extension.

I’m not sure, but I imagine it would be possible to get a newer Jupyterlab installed when you’re provisioning the VM.

1 Like

@TomAugspurger, following your suggestion, I installed the latest version of JupyterLab and dask extension in a separate VM. After accessing the new VM through SSH connection, I launched Jupyter lab and immediately it returns a pop-up error “Failed to list clusters: might the server extension not be installed/enabled?”. I see this was reported already in issue #87.

FYI, I’m expecting to set clusters via the dask cloud provider instead of using the local ones. The image below shows no success with enter or search button.