Deploying pangeo

I deployed a single-user dask-jupyter helm chart on a k8s cluster (helm-chart/dask at main · dask/helm-chart · GitHub).

$ helm ls

NAME  	NAMESPACE      	REVISION	UPDATED                             	STATUS  	CHART         	APP VERSION
pangeo	wifire-quicfire	6       	2021-11-22 15:29:38.809774 -0800 PST	deployed	dask-2021.11.2	2021.11.2  

$ kubectl get svc pangeo-dask-jupyter pangeo-dask-scheduler

NAME                    TYPE        CLUSTER-IP      EXTERNAL-IP   PORT(S)           AGE
pangeo-dask-jupyter     ClusterIP   10.105.206.19   <none>        80/TCP            20h
pangeo-dask-scheduler   ClusterIP   10.107.121.88   <none>        8786/TCP,80/TCP   20h

I’m trying to expose an external ip. My k8s does not allow the use of the LoadBalancer service so I’m trying to enable the ingress instead.

For exposing an external ip, I’m trying to enable ingress following this template:

Here’s the ingress part of my values.yaml:

Screen Shot 2021-11-23 at 11.18.34 AM

When I run the update, here’s my error:
$ helm upgrade pangeo -f values.yaml dask/dask

Error: UPGRADE FAILED: YAML parse error on dask/templates/dask-jupyter-ingress.yaml: error converting YAML to JSON: yaml: line 19: mapping values are not allowed in this context

Does anyone have any suggestions for configuring the YAML for ingress?

1 Like

Thanks for the question @ben!

This is not my area of expertise. I can point you to a few resources though.

Here is the latest chart for the current Pangeo Cloud cluster on GCP. Maybe there is something helpful in there.

Have you tried asking this directly on the dask/helm-chart repo?

The yaml from the Pangeo Cloud cluster on GCP is a helpful reference, @rabernat.

That’s a good idea posting directly to dask/helm-chart repo. I just went ahead and did that. Thanks!